Overall slowdowns on the platform
Incident Report for Shipfix
Resolved
The issue has been resolved.
Posted Jul 27, 2023 - 10:20 UTC
Update
We are currently investigating this issue.
Posted Jul 27, 2023 - 10:00 UTC
Investigating
We are currently investigating this issue.
Posted Jul 27, 2023 - 08:21 UTC
This incident affected: Email Inbound, Market Monitor, and Maps.