Slowdown on email inbound
Incident Report for Shipfix
Resolved
This incident has been resolved.
Posted Sep 11, 2023 - 10:33 UTC
Identified
An abnormal load on our search engine has been detected. Email inbound and data extraction are impacted. Action is being taken.
Posted Sep 11, 2023 - 08:47 UTC
Investigating
We are currently investigating this issue.
Posted Sep 11, 2023 - 08:40 UTC
This incident affected: Email Inbound.